GD Star Rating
loading...

Привет, цисканы!
Я что-то затупил, не могу второй айпишник повесить на 2801

От провайдера по одному проводу приходят две сети 83.111.222.248/29 и 109.113.227.240/29 (из-за бюрократии, раньше канал был 20 мбит/с, теперь как бы два по 10 мбит/с, но с недавних пор скорость перестала быть двадцаткой и стала только десяткой.
Конфиг:
interface FastEthernet0/0
ip address 83.111.222.251 255.255.255.248
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto!
interface FastEthernet0/0.1
ip nat outside
ip virtual-reassembly in!
interface FastEthernet0/1
ip address 10.0.0.1 255.0.0.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto

Пытаюсь вбить ео на Fa0/0.1:
R1(config)#interface fastEthernet 0/0.1
R1(config-subif)#ip address 109.113.227.242 255.255.255.248

Пишет
% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.

Что я делаю не так?

Tagged with →  

32 Responses to не могу второй айпишник повесить на 2801

  1. Sseef:

    Router(config-if)#int fa0/0.1
    Router(config-subif)#encapsulation dot1Q 1

  2. Sseef:

    А вообще лучше использовать secondary ip-адрес:

    Router(config)#interface fa0/0
    Router(config-if)#ip address 83.111.222.251 255.255.255.248
    Router(config-if)#ip address 109.113.227.242 255.255.255.248 secondary

  3. Lacblack:

    спасибо!

  4. Sseef:

    ты отпишись как там, работает или нет. А то я начинающий сварщик.

  5. NibMega:

    не, про секондари правильно сказал.

  6. Lacblack:

    на тестах исходящая все равно около 10. второй айпишник натить надо как-то?

  7. Sseef:

    по идее secondary будет использоваться, если есть проблемы с primary. То есть сейчас secondary неактивен. Можно проверить трассировкой. А какая маршрутизация с провайдером? BGP?

  8. Kcubad:

    роутер будет ВСЕГДА отправлять пакеты только с primary. так не будет работать, я думаю

  9. Lacblack:

    то есть надо поднимать fa0/0.1 или какую-то группу товарищей выпустить с
    ip nat inside source static tcp 10.0.0.3 interface FastEthernet0/0.1 ?

  10. Lacblack:

    а я хз, провод с интернетом приходит и настройки дали.

  11. Sseef:

    я бы делал load balancing через маршрутизацию.

  12. Kcubad:

    да, поднимаешь саб в первом влане, назначаешь ему второй адрес. а как ты собираешся разделять, кто через какой канал пойдет?

  13. NibMega:

    Короче, коллеги подсказали, что без помощи провайдера и работы на его стороне – никак не получится 10+10=20 сделать.

  14. Kcubad:

    а почему, не подсказали?)) все там получится. по отдельности каналы работают?

  15. Lacblack:

    я 83.111.222.248/29 вырубить не могу, на ней фтп, почта и удаленка висят.

  16. Kcubad:

    поднял сабинтерфейс? попингуй с него наружу.

  17. NibMega:

    Рулёж на L3 нужен, роутинги у прова прописывать надо. Как вариант – bgp поднимать: угондошить таки воробья из пушки.

    А теперь расскажи, как бы ты суммировал циской на стороне абонента два тарифа по 10 мегабит в одной физике для получения 20 мегабит и разграничил шлюзы если не попакетно, то по отдельным приложениям хотя бы? Я вот как ни думаю – никак не выходит без участия прова.

  18. Sseef:

    ну почему воробья из пушки? Стандартный bgp multihomed дизайн. Пров должен отдавать только дефолтный гейтвей.

  19. Irire:

    Ну почему. Если у тебя основной поток данных – это NAT, то адреса примари и секондари на одном интерфейсе. И развести направления по разным пулам разных провайдеров. на основе роутмапов.
    ну или сделать изврашение – прописать два деволтгейтвея с одинаковый метрикой, настроить CEF, понатить весь поток на основе роутмапов и и балансоровку оставить на откуп черной коробочке с надписью MAGIC. В пределах однйо трансляции данные будут идти все время на одного прова. Но в случае сборных сайтов, у котороых атворизация не на тех серверах, что и основнйо контент будет регулярно отваливаться авторизация. Ибо кукисы будут совершенно не соответствовать.

  20. Irire:

    а лучше договориться с провом, чтоб он вам отдавал все по одной сетке. ибо все это танцы.

  21. Yb_Nix:

    Что мешает использовать ip nat pool?

  22. Yb_Nix:

    По задаче две сети от одного провадера. Два default тут не нужно.

  23. Irire:

    как я понял, что провайдер у него шейпит каждую подсеть на 10мб
    поэтому предлажил два пути для получения пропускной от обоих подсетей.
    1. просто пронатить полльзователей через одного через два разных пула из разных подсеток, отлавливая заблудившиеся пакеты роутмапами.
    2. включить CEF + два def_gw с одинаковыми метриками. тогда циска начнет алансировать потоки через оба шлюза. CEF для управления потоками.
    ну и опять роутмапы для отслеживания и отлавливания потоков трафика. ну и по дороге к провайдеру все пользовательские сессии натить пулами в зависимости от того, через какой они гв прут. но тут тогда лучше сделать два саб интерфейса, чтоб было по какому признаку матчить.

  24. Lacblack:

    незнание?

  25. Yb_Nix:

    Тут потоков отличных от заначеных нет, потому два гейта не нужны. Даже роутмапы скорее не нужны, достаточно оба диапазона загнать в один ip nat pool

  26. Yb_Nix:

    Global Configuration Commands
    • Defining a pool
    ip nat pool { netmask
    | prefix-length } [ type { rotary } ]
    Defines a pool of addresses using start address, end address, and netmask. These addresses will be allocated as needed.

  27. Kcubad:

    ничего не понял. зачем какой-то отдельный роутинг прописывать у прова? по каким отдельным приложениям? вот сейчас набросал конфиг, все работает нормально. но не через сабинтерфейсы, а через secondary ip все-таки.

  28. NibMega:

    у тебя траф как делится между ip?

  29. NibMega:

    primary и secondary сетями, я имел в виду

  30. Kcubad:

    трафик делится ацл. не знаю, заработало ли это у ‘a, но у меня была идея разделить внутреннюю подсеть пополам, и половину выпускать в один шлюз, половину в другой. причем пополам “через одного”, вот таким ацл примерно:

    access–list 10 permit 192.168.10.0 0.0.0.254
    access–list 11 permit 192.168.10.1 0.0.0.254

  31. NibMega:

    в этом случае циска уж точно в роли микроскопа для забивания гвоздей.

Добавить комментарий